知足常乐

日常学习的记录与分享

Vlan间通信

什么是路由

选择一个将数据包发往某个目标网段或主机的路径就是路由的过程。

《Vlan间通信》

作用

实现不同IP网段主机间的相互访问

实现不同通信协议网段主机间的相互访问

不转发广播数据包

功能

基于IP地址的寻径和转发

不同通信协议的转换

特定IP数据包的分片和重组

单交换机VLAN的路由器连接方式1:多条链路连接多个VLAN

当有一个交换机组成多个VLAN时,路由器采用多个端口连接多个VLAN。右图的交换机有3个VLAN,那么交换机与路由器间就需要三个连接端口及线缆。这样在不同的线路上配置不同的子网地址及路由即可。但是需要太多的路由器接口,所以这种方法不实用。

《Vlan间通信》

单交换机VLAN的路由器连接方式2:一条链路连接多个VLAN

当有一个交换机组成多个VLAN时,路由器只采用一个端口连接多个VLAN。利用子接口技术(SubInterface)将所有VLAN的数据通过一个端口传输。

VLAN将交换机从逻辑上分割成了多台,因而用于VLAN间路由的路由器也必须拥有分别对应各个VLAN的虚接口(SVI)作为各个VLAN成员的网关。这样各个VLAN之间就可以利用路由器来实现数据交换。

《Vlan间通信》

单臂路由:使用IEEE 802.1Q来启动一个路由器上的子接口成为干道模式 ,实现VLAN之间的通信

《Vlan间通信》

网络规划

《Vlan间通信》

基本配置讲解


Router(config)# Interface interface-id //进入路由器接口配置
Router(config-if)#no ip address //删除该口ip配置
Router(config-if)#exit //退回上层
Router(config)#interface fastethernet slot-number/interface-number.subinterface-number //进入svi虚接口
Ruijie(config-subif)#encapsulation dot1Q VlanID  //对vlan进行封装
Router(config-subif)#ip address ip-address mask //配置该虚接口的ip和mask

配置

Cisco Packet Tracer 模拟器 

交换机上配置

switch#configure terminal 
//创建vlan10,20,30
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#
Switch(config)#vlan 30
Switch(config-vlan)#
Switch(config-vlan)#exit
//0/24口开启truck口
Switch(config)#interface fastEthernet 0/24
Switch(config-if)#switchport mode trunk 
//分别将各口加入各自vlan
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/3
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit


在路由器上配置

Router(config)#interface fastEthernet 0/0
Router(config-if)#no ip address 
Router(config-if)#exit

Router(config)#interface fastEthernet 0/0.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
Router(config-subif)#exit

Router(config)#interface fastEthernet 0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
Router(config-subif)#exit

Router(config)#interface fastEthernet 0/0.30
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip address 192.168.30.1 255.255.255.0
Router(config-subif)#end
//手动开启接口
interface fastEthernet 0/0
Router(config-if)#no shutdown 

点赞
  1. 小黑说道:

    good

发表评论

电子邮件地址不会被公开。 必填项已用*标注